Безопасность в глобальной сети Интернет

Wireshark исправили три недостатка, которые позволяли проводить DoS-атаки

Недавно Wireshark исправил три различные уязвимости безопасности в своей системе. Сообщается, что все трое имели высокий уровень тяжести с базовым счетом 7,5. Эти уязвимости, обнаруженные Cisco, могут позволить злоумышленнику проводить DoS-атаки, приводя к сбою системы.

Cisco открыла три уязвимости безопасности, запускающие DoS-атаки

Недавно исследователи из Cisco обнаружили три различных недостатка безопасности в Wireshark – анализатор сетевых протоколов. Все три из них могут вызвать атаки DoS при эксплуатации.

Эти уязвимости были обнаружены в Cisco, и они обнаружили, что они вызывают сбои системы аналогичного характера.

Все эти уязвимости могут позволить злоумышленнику «внедрить неверный пакет в сеть». Затем эксплуатируемое приложение обработает вредоносный пакет или пользователь может открыть файл с помощью вредоносного пакета. В конечном итоге это может привести к сбою приложения, что приведет к условию DoS.

Как указано в анализе уязвимостей Cisco:

«Чтобы использовать уязвимость, злоумышленник может использовать вводящий в заблуждение язык и инструкции, чтобы убедить пользователя открыть файл трассировки вредоносных пакетов. Чтобы внедрить неверные пакеты, которые приложение Wireshark может попытаться проанализировать, злоумышленнику может потребоваться доступ к доверенной внутренней сети, в которой находится целевая система. Это требование доступа может снизить вероятность успешного использования ».

Уязвимости обнаружены в компоненте протокола Bluetooth Attribute Protocol (ATT), компоненте диссоциации Radiotap и компоненте-диссекторе передачи аудиовизуального распространения (AVDTP) Wireshark. Им были присвоены номера CVE CVE-2018-16056, CVE-2018-16057 и CVE-2018-16058 соответственно. Как объяснили исследователи относительно протокола атрибутов Bluetooth (ATT)

«Уязвимость существует из-за того, что файл исходного кода epan / dissectors / packet-btatt.c поврежденного программного обеспечения не проверяет наличие диссектора для конкретного универсально уникального идентификатора (UUID)».

В то время как дефект компонента диссоциации Radiotap произошел из-за «недостаточной проверки привязки функции ieee80211_radiotap_iterator_next ()». Аналогичным образом, недостаток в компоненте диссоциатора AVDTP возник из-за неправильной инициализации структуры данных файлом исходного кода epan / dissectors / packet-btavdtp.c.

Кроме того, исследователи также заявляют, что POC для использования недостатков в режиме реального времени является общедоступной.

Wireshark исправил недостатки

Wireshark подтвердил, что три уязвимости безопасности, обнаруженные Cisco, затронули версии 2.6.0 до 2.6.2, 2.4.0 до 2.4.8, 2.2.0 до 2.2.16. В конце концов, они быстро исправили все три недостатка в последних обновлениях. Поставщики выпустили исправления 29 августа 2018 года. Позже Cisco раскрыла подробности об уязвимостях для общественности 30 августа 2018 года. Пользователи могут защитить себя от уязвимостей, обновив их до последних версий 2.6.3, 2.4.9, 2.2.17 или более поздние версии. Они могут загружать последние версии с веб-сайта Wireshark.

Подписывайтесь на обновления сайта, а также наш Telegram.

Теги

nelus

Программист, SEO специалист, GEEK, увлекаюсь новостями из мира IT и безопасностью программного обеспечения.

Related Articles

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Back to top button